Autor Thema: Xming  (Gelesen 6236 mal)

tba

  • Gast
Xming
« am: 03. Dezember 2006, 15:04:07 »
Hallo Freunde,
ich habe da ein kleines aber ärgerliches (weil ich nix verstehe) Thema mit Xming (freier guter X-Server für Win32):

Gehe mit Xming (auf Windows XP) via XDMCP an eine schöne alte SPARCstation 4 mit Solaris 9. Meines Wissens nach nutzt Xming eine SSH-Verbindung(?) - jedenfalls will ich die Sprache LANG=de_DE.ISO8859-15 (de_DE@euro) nutzen, unter Xming kann ich dann aber kein "€" geschweige denn irgendeinen Umlaut darstellen.

Wenn ich LANG=de_DE.ISO8859-1 (de_DE) beim Start der Session auswähle, werden wenigstens die Umlaute dargestellt. Ich habe versucht anstatt das Fontpaket von Xming die SPARC als FontServer zu nutzen; das tut mit dem gleichen schlechten Ergebnis.

Im Unterverzeichnis des Xming (auf XP) gibt es ein C:\Programme\Xming\locale\iso8859-15 - ich weiss aber nicht ob und wie ich das nutzen kann.

Noch etwas interessantes. Eine Überprüfung im gestarteten Desktop von Xming ergibt mit
~$ locale
LANG=de_DE.ISO8859-15
LC_CTYPE=de_DE.ISO8859-15
LC_NUMERIC=de_DE.ISO8859-15
LC_TIME=de_DE.ISO8859-15
LC_COLLATE=de_DE.ISO8859-15
LC_MONETARY=de_DE.ISO8859-15
LC_MESSAGES=de
LC_ALL=

Auf der Sun in einer lokalen X-Session ist dort LC_CTYPE=de_DE.ISO8859-1 (der Rest gleich), aber der Euro wird dargestellt!

Ich habe diverse man-pages und Manuals durchgeackert, bin aber offensichtlich zu blöd zu verstehen, was der Unterschied zwischen locale und font ist bzw. wo ich was einstellen muß.

Danke für die Mühe die euch mache  ;D

Gruß
thorsten

sonnenblen.de - Das unabhängige Sun User Forum

Xming
« am: 03. Dezember 2006, 15:04:07 »

Offline msueper

  • Sobl Junior
  • **
  • Beiträge: 96
Re: Xming
« Antwort #1 am: 04. Dezember 2006, 19:57:54 »
Hallo,
von zu Hause aus nutze ich auch putty und xming um an die SUNs bei uns zu kommen. Umlaute sind bei mir kein Problem, € geht nicht.
Von xming kommen aber ziemlich oft neue Versionen, weil Cygwin den X-Server regelmäßig akualisiert. Ggf. geht es ja in der neuen Version schon.

set | grep LC

LC_COLLATE=de_DE.ISO8859-15
LC_CTYPE=de_DE.ISO8859-15
LC_MESSAGES=de
LC_MONETARY=de_DE.ISO8859-15
LC_NUMERIC=de_DE.ISO8859-15

LANG ist ungesetzt.
Bei xming habe ich nichts weiter eingestellt und im Putty einfach mal xterm gestartet. Zum xming gibt es auch ein "fettes" Fonts-Paket (download auf der Seite von xming).
Martin
« Letzte Änderung: 04. Dezember 2006, 20:00:09 von msueper »

tba

  • Gast
Re: Xming
« Antwort #2 am: 04. Dezember 2006, 22:16:20 »
Hallo Martin,
da hatte ich eine schöne Antwort geschrieben - und schwupps war der Server wech .. also neuestes Xming und Font Pack habe ich (und habe ich probiert) - kein Erfolg.

Die Umalute kommen bei mir ja auch bei manueller Auswahl de_DE.ISO8859-1 im dtlogin. Xming scheint nicht zu erkennen, daß ich default mit de_DE.ISO8859-15 starte und "wählt" dann wohl POSIX-Standard - weder Umlaute noch Euro - interessant ist daß die Sun wohl die Tasten entgegennimmt (wird ein Blank dargestellt anstatt "beep" für unbekannte/unbelegte Tasten. Deshalb vermute ich den Fehler bei Xming.

Für den PuTTY mußte ich (bei Umstellung auf ssh anstatt Telnet) eine $HOME/.ssh/environment erstellen und die Einstellungen für locale dorthineinpacken - dann läuft PuTTY (0.58) perfekt!