Autor Thema: Neu installiertes System  (Gelesen 9155 mal)

Gandalf

  • Gast
Neu installiertes System
« am: 14. Dezember 2008, 14:31:45 »
Hallo zusammen,
ich war lang nciht mehr hier, weil mein System einfach nur rannte ( BSD 5.4)
Leider hatte ich jetzt eine Platten Fehler ( Defekte Sektoren) und habe mir ein neues System aufgesetzt.
Da ich das Home un das WWW verzechniss seperat auf einem Raid habe, und bei der Inst. kein Home mit angegeben habe, wollte ich nun das verzeichniss mit in die FSTAB packen.
die beiden Labels lauten aacd0s1d und aacd0s1e
Mein Frage ist nun wie kann ich die wieder einbinden.
habe es probiert mit
/dev/aacd0s1d         /home           ufs     rw              2       2
/dev/aacd0s1e         /www            ufs     rw              2       2
aber damit klappte es nicht.

Das komplette System rennt auf SCSI Basis wie ihr seht
Hat einer ne Idee ?
Die User haben auch alle wieder die selbe ID bekommen beim anlegen. Damit müßten sie auch wieder drauf zu greifen können, was bis jetzt aber nciht klappt

sonnenblen.de - Das unabhängige Sun User Forum

Neu installiertes System
« am: 14. Dezember 2008, 14:31:45 »

Offline Padde

  • Sobl Bachelor
  • ***
  • Beiträge: 135
  • Hier könnte Ihre Werbung stehen!
Re: Neu installiertes System
« Antwort #1 am: 14. Dezember 2008, 15:33:09 »
"Klappt nicht" ist keine sonderlich hilfreiche Beschreibung des Fehlers. Welche Fehlermeldung bekommst du denn?

Generell solltest du natürlich überprüfen, ob /home und /www als Verzeichnisse(!) existieren. Wenn du bei der Installation kein separates /home angelegt hast, ist /home kein Verzeichnis, sondern ein Symlink auf /usr/home. Und /www existiert standardmäßig sowieso nicht.

Und natürlich solltest du auch prüfen, ob du wirklich /dev/aacd0s1d und /dev/aacd0s1e hast. Diese Devices müssen in /dev vorhanden sein; am besten mal ein ls -l /dev/aacd* machen.

Die /etc/fstab sieht ansonsten gut aus.

Gandalf

  • Gast
Re: Neu installiertes System
« Antwort #2 am: 14. Dezember 2008, 17:01:59 »
Also hier mal die aacd abfrage
ls -l /dev/aacd*
crw-r-----  1 root  operator    0,  86 Dec 13 18:24 /dev/aacd0
crw-r-----  1 root  operator    0,  87 Dec 13 18:24 /dev/aacd0s1
crw-r-----  1 root  operator    0,  88 Dec 13 18:24 /dev/aacd0s1c
crw-r-----  1 root  operator    0,  89 Dec 13 18:24 /dev/aacd0s1d
crw-r-----  1 root  operator    0,  90 Dec 13 18:24 /dev/aacd0s1e

Alles soweit da
und Home ist tatzächlich unter usr.
Die waren allerdings vorher im / verzeichniss
Wie kann man nun vorgehen/ hingehen und das dort wieder hin bekommen ?

Offline Padde

  • Sobl Bachelor
  • ***
  • Beiträge: 135
  • Hier könnte Ihre Werbung stehen!
Re: Neu installiertes System
« Antwort #3 am: 14. Dezember 2008, 17:46:29 »
Wie schon erwähnt: Erstelle die Verzeichnisse /home und /www, dann sollte auch deine /etc/fstab funktionieren. (Falls nicht noch was anderes klemmt - dafür wäre halt mal die genaue Fehlermeldung wichtig.)

Gandalf

  • Gast
Re: Neu installiertes System
« Antwort #4 am: 14. Dezember 2008, 19:07:15 »
Das komische ist , das es in der root also / schon ein Home verzeichniss gibt, das auf die Daten der jeweiligen User zu greifft. Wie kann ich denn da daruf jetzt einen Mount point setzten?
Ich denke mir das es sich hierbei um einen symbolischen link handelt der dann auf die /usr/home zu greift

sonnenblen.de - Das unabhängige Sun User Forum

Re: Neu installiertes System
« Antwort #4 am: 14. Dezember 2008, 19:07:15 »

Offline Padde

  • Sobl Bachelor
  • ***
  • Beiträge: 135
  • Hier könnte Ihre Werbung stehen!
Re: Neu installiertes System
« Antwort #5 am: 14. Dezember 2008, 20:41:20 »
Ja, das ist so, siehe Antwort #1. Kannst du auch mit ls -ld /home nachprüfen.

Also, hier nochmal zwecks C&P: rm /home && mkdir /home

Ich hoffe, dein FreeBSD läuft wenigstens auf Sun-Hardware. :P

Gandalf

  • Gast
Re: Neu installiertes System
« Antwort #6 am: 15. Dezember 2008, 08:30:46 »
Guten morgen Padde,
ne es ist ein Dell Server ein älteres Model nen
Power Edge 4500 mit einem Perc Raid Controller.
Insgesamt sind es drei SCSI Controller zwei onboard und
einmal eben der Raid Controller.
4 GB Speicher und 6 Platten Schächte.
Ist nen schickes Teilchen. Für 100 Euro :-)

Gandalf

  • Gast
Re: Neu installiertes System
« Antwort #7 am: 15. Dezember 2008, 12:09:11 »
Also
Das mit dem WWW konnte ich machen. Klar. DA Verzeichniss existierte nicht. Also www angelegt und mit dem oben genannten befehl das Verzeichnis gemountet.
klappte auf anhieb.
Nur das Home Verzeichniss funzt nett.
Obwohl ich ja kein home angegeben habe, existiert wie schon oben erwähnt unter /usr/home eins
Zusätzlich jetzt auch eins in der root.
Leider kann ich mit dem befehl
rm /home && mkdir /home
nicht das verzeichniss löschen und wieder herstellen.
nach dem oben genannten Befehl kommt
rm: /home: is a directory
Ich denke mir es hat was mit dem Symlink zu tun. Wie kann man den löschen? ha schon gegoogelt aber nichts gefunden. Hast du da noch ne Idee?
Auch wenn ich in das verzeichiss reingehe, bin ich in den jeweiligen Benutzerordnern. D.h. er greift ja schon drauf zu.

claus

  • Gast
Re: Neu installiertes System
« Antwort #8 am: 15. Dezember 2008, 18:46:35 »
Die User-Verzeichnisse sind schon da?

Was ist dann eigentlich noch das Problem?

Claus

Offline Padde

  • Sobl Bachelor
  • ***
  • Beiträge: 135
  • Hier könnte Ihre Werbung stehen!
Re: Neu installiertes System
« Antwort #9 am: 15. Dezember 2008, 22:16:26 »
Verstehe ich auch nicht. Wenn /home als Verzeichnis existiert (wo auch immer das jetzt plötzlich her gekommen sein mag), sollte es wohl kein Problem mehr sein, das auf dem RAID befindliche Dateisystem dort hin zu mounten.

Nach dem Verlauf dieses Threads zu urteilen möchte ich mal behaupten, daß der OP nicht mit der Organisation eines UNIX-Dateisystems vertraut ist und daher den Überblick auf seinem System verloren hat. Wahrscheinlich funktioniert mittlerweile alles so wie es soll, er hat es nur noch nicht gemerkt.

Im Übrigen ist dieses Unterforum für FreeBSD auf SPARC-Hardware da...  ::)

sonnenblen.de - Das unabhängige Sun User Forum

Re: Neu installiertes System
« Antwort #9 am: 15. Dezember 2008, 22:16:26 »

Gandalf

  • Gast
Re: Neu installiertes System
« Antwort #10 am: 16. Dezember 2008, 09:09:28 »
Ok ich probier es mal anders.
Ich habe mir ein System komplett neu aufgebaut. Also Platte in einem anderen Rechner geschoben installiert und das alles ohne das Home und www Verzeichniss anzu geben.
Habe dann angefangen eine DNS soweit aufzu setzten ( ich mache das alles aus der ferne, da ich nciht vor ort bin)
Dann habe ich die Platte in den vorhandenen Server gesteckt. Dort befindet sich ein Raid system drauf mit den beiden Verz. home und www.
Nach anlegen des www verzeichnisses und anschließendem mounten konnte ich das besagte verzeichniss mounten. Ist auch soweit da.
Da ich das System ohne home angelegt habe, hat bsd ja unter /usr/home ein home angelegt.
Aus welchen Gründen auch immer war es nach dem start im Server auch auf der Root.
So ich denke bis hier hin ist alles klar.
Mein frage ist nun, da ich es nicht in der fstab drin stehen habe, und es auch nirgendswo steht, dachte ich mir das ich das home da noch rein mounten muss. es ist noch kein samba auf dem System installiert so das ich es auch mit einem mac oder eine windows kist nicht testen kann, ob die user da drauf kommen und Ihre Daten verwalten könnten. Daher die Frage, wie kann ich die Daten in das Verzeichniss /home mounten, da ja wie geschrieben nichts in der fstab drin steht.
Wenn ich probier das Home vom raid in das /home zu mounten kommt wie gesagt der fehler
mount: /dev/aacd0s1d : operation not permitted
Das ist das was ich nciht ganz verstehe.

So und nun das witzigeste. Ich hab ja wie gesagt im der / das home verzeichniss.
Da ist aber leer.  Habe gerde nach geschaut.
Das unter /usr/home ist voll. Also da gibt es die Benutzer Ordner. Sund und nun geht es darum das die auf dem Raid befindelichen Daten sich im Home verzeichniss auf / befindet.
Und da ist die Frage wie mach ich das
« Letzte Änderung: 16. Dezember 2008, 11:47:53 von Gandalf »

Gandalf

  • Gast
Re: Neu installiertes System
« Antwort #11 am: 16. Dezember 2008, 12:53:25 »
Asche auf mein haupt.
Habe den Fehler gefunden. Manchmal braucht man eine Gehirnwindung weniger oder mehr je nachdem.
Folgendes war.
Aus welchen Gründen auch immer stand unter /usr/home das home eben drin vom Raid.
Also ich habe es nicht da rein geschrieben sonder das system Warum ?? Keien Ahnung.
Mir ist dann endlich der Befehl "df" eingefallen und sie da, das System hat das Teil gemountet.
Also ein beherztes "umount /usr/home" brachte aber dann immer den Fehler " operation not permitted" oder ähnlich.
Habe dann mit " umount -f /usr/home" es probiert und siehe da es liess sich unmounten.
Dann ein mount hinter her geschoben auf das /home verz. und alles ist wieder an seinem Platz. Man.
So nun meine Frage wenn ich nun in der fstab die Mountpoint so anlege
/dev/aacd0s1d         /home           ufs     rw              2       2
/dev/aacd0s1e         /www            ufs     rw              2       2

Nimmt er es dann an ? Mountet er dann home in /home
Müßte er eigentlich oder ? Weil ich es beim letzt booten auch drin hatte und er den bootvorgang gestoppt hat. Behält er die letzte Position ? Weil wenn er es automatisch in /usr/home reinlegt, wie verhält er sich dann beim nächsten booten?
« Letzte Änderung: 16. Dezember 2008, 12:56:16 von Gandalf »

juedan

  • Gast
Re: Neu installiertes System
« Antwort #12 am: 23. Dezember 2008, 21:31:12 »
Moin,

Habe dann mit " umount -f /usr/home" es probiert und siehe da es liess sich unmounten.

Es wäre besser gewesen, Du hättest vorher mit
#mountüberprüft, ob /usr/home wirklich irgendwie gemountet ist - was sich bezweifle.
Poste doch bitte mal die Ausgabe von mount.

Zum Thema /home aufs RAID legen.
Wenn Du beim Anlegen der Mount-Points kein Label für /home angelegt hast, dann ist das ein symbolischer Link nach /usr/home, was Du leicht mit ls -las überprüfen kannst.
Wenn aber bei einem rm /home die Meldung rm: /home: is a directory kommt, dann ist das auch ein Directory und deutet auf einen Mount-Point hin.
Was sagt denn
# bsdlabel da0s1
Mfg UNIXer

Gandalf

  • Gast
Re: Neu installiertes System
« Antwort #13 am: 27. Dezember 2008, 13:33:11 »
Hallo Unixer
also auf bsdlabel da0s1 kommt das hier
Zitat
# /dev/da0s1:
8 partitions:
#        size   offset    fstype   [fsize bsize bps/cpg]
  a:  1572864        0    4.2BSD     2048 16384 28552
  b:  2521638 33030144      swap                   
  c: 35551782        0    unused        0     0         # "raw" part, don't edit
  d:  8388608  1572864    4.2BSD     2048 16384 28552
  e:  8388608  9961472    4.2BSD     2048 16384 28552
  f: 14680064 18350080    4.2BSD     2048 16384 28488