Autor Thema: Installations-Hints fuer debian 5.0.4 auf einer SUN Fire V100  (Gelesen 3509 mal)

guidol

  • Gast
Installations-Hints fuer debian 5.0.4 auf einer SUN Fire V100
(zur eigenen Gedankenspeicherung und Hilfe fuer andere)

Die meisten Tipps stehen auch schon auf http://www.tux-admin.de/v100/index.shtml
(Danke dafuer an den Tux-Admin, der hier wohl aunda als User heisst(?))

1.) Verbindungaufnahme zur V100
Da die V100 (wie die Netra X1) zwei serielle RJ45-Ports
nutzt, braucht man erstmal ein CISCO Console-Kabel
um mit dem LOM-Port Kontakt aufnehmen zu koennen
(bei e*ay hab ich meins fuer 3,50EUR inkl. Porto bekommen)

Dazu (fuer Windows wenn man dies nutzt) ein Terminalprogramm
dass besser als HyperTerminal eine VT-Emulation unterstuetzt.
Hier z.B. Tera Term 4.64 oder einen aktuellen puTTY
(Win7 scheint kein HyperTerminal mehr zu haben)

mit 9600Baud und 8N1 kann dann also losgehen….

Wenn man nun die V100 mit dem PC verbunden hat und das
konfigurierte Terminalprogramm gestartet hat, erhaelt man
nach dem Anlegen vom Strom und ggf druecken der ENTER-Taste
die Eingabeaufforderung lom> (Lights Out Management)

Da die V100 so natuerlich noch richtig eingeschaltet ist,
gibt man dem LOM den Befehl
poweron

Nun sollte die V100 (nach dem Speichertest) vom LOM zum
OBP (Open Boot PROM) wechseln.

Da die V100 meist "nur" mit CDROM kommt, nahm ich zum installieren die
NetInstall-CD von debian.

Am ok Prompt des OBP kann man dann die Install-CD booten mit:
boot cdrom

So, jetzt kommt schon der erste Haken von debian mit einigen SPARC-Maschinen:
Wuerde man einfach den Boot mit der ENTER-Taste starten, wuerde die V100
nach Erkennung der Festplatten haengenbleiben, da es wohl im Treiber fuer den
Chipsatz noch immer ein Problem mit dem DMA des IDE-Controllers gibt
(erinnert mich an meine Install-Versuche auf einer Blade 100)

Die Loesung dazu ist am Boot-Prompt folgendes einzugeben:
expert ide=nodma

Nun bootet der Installer schon viel besser und macht auch weiter nach Erkennung der
Festplatten (max. 120GB je Platte)

Wenn man jetzt das Installer-Menue sieht, kommt man auch schon zum 2ten Haken bei
der debian-Installation: debian will von Haus aus die Netzwerkkarte lieber mit dem
Treiber/Modul dmfe (davicom) anstatt mit dem tulip versorgen.
Da man aber mit dem dmfe z.Zt. wohl nie ins Netz kommen wird, musss mann
im Installer-Menue erstmal in die Shell (ganz unten im Menue) wechseln
(siehe hierzu auch http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=496945)
In der Shell gibt man folgende Befehle ein (ohne die man sont nie einen
Mirror ereichen koennte):
 modprobe -r dmfe
 modprobe -r tulip
 modprobe tulip

und wechselt mit exit zurueck zum Installer-Menue


Durch die Eingabe am Boot-Prompt "expert ide=nodma" ist die debian-Installation
jetzt nicht ganz so komfortabel wie normal, aber man kann nu jeden Punkt nacheinander
durcklicken im Installer-Menue un kommt zum Schluss zum selben Ergebnis.

Verwunderlich mag fuer einige sein, dass nicht die normalen Installer-Menuepunkte alle da sind,
aber die erscheinen erst wenn man am Punkt angekommen ist, an dem weitere Module (hier nicht
unbedingt Treiber sondern Install-Module) nachgeladen werden.

Leider bekommt man im expert-Modus auch keine Auswahliste der Mirrors, so dass man
wie ich z.B. per FTP auf ftp2.de.debian.org zurueckgreift.

Hat man dann die Partition der Platten geschafft
================================================
(irgendwie wurden nur 10GB meiner ersten 40GB-Platte erkannt obwohl keine Partition mehr zu sehen ist,
so dass ich die gesamten 40Gb meiner 2ten Platte als / (Root) genommen habe…
SWAP hab ich keinen eingerichtet da 1Gb Ram vorhanden sind bei mir und nach Boot nicht mal 100MB verbraucht wurden)
================================================
und die Base-Installation und Paketauswahl abgeschlossen kann der erste Neustart kommen
(die CD kommt ja automatisch raus)

Evtl. gibt man nun noch im OBP-ok-Prompt
boot disk
ein

ABER da erwischt und wieder der 1ste Haken:
Die Installation von debian erfolgte ja mit der Option ide=nodma, die dass System
nun aber nicht kennt…
Abhilfe schafft fuers Erste am Boot-Prompt die Eingabe
Linux ide=nodma
(hierbei darauf achten, dass Linux mit grossem L anfaengt, denn so steht es
in der /boot/silo.conf als Alias)

Silo ist der LinuxLoader fuer SPARC.
Um sich die Eingabe beim naechsten Neustart zu sparen aendert man die
/boot/silo.conf bzw. die /etc/silo.conf (obwohl die bei meinem debian auch nur
auch die /boot/silo.conf verweist) so mit dem Editor vi ab im Bereich des Standard-Alias
Linux:

image=/boot/vmlinuz
   label=Linux
        append="ide=nodma"
    initrd=/boot/initrd.img

Wichtig, wie man sieht, ist die zusaetzliche append-Zeile.
Da Linux schon der standarsmaessig ausgewaehlte Eintrag ist,
haengt man damit das notwendige ide=nodma automatisch an

Datei speichern und beim nachsten Neustart bleibt deian auch da nicht mehr haengen :-)

Fein, nun startet debian von selber durch…..
ABER nun trifft uns immer noch der 2te Haken nach dem Neustart, d.h. es ist kein Netzwerk
verfuegbar, weil debain immer noch das dmfe-Modul anstatt dem tulip bevorzugt.

Also erstmal wieder von Hand den richtigen Treiber zuweisen durch Eingabe von
 modprobe -r dmfe
 modprobe -r tulip
 modprobe tulip

Ein erster Blick per Google ins Netz stellte die /etc/modprobe.d/blacklist als
Ziel in Aussicht um das Problem zu loesen.
D.h. man hatte dort die dmfe als blackgelisteten Treiber eingetragen neu gestartet
und debian haette den dmfe nicht mehr geladen…  waer aber zu einfach gewesen.

Auch die vom Tux-Admin (s. Seite ganz oben) genannte blacklist.local brachte selbst erstellt
bei mir keine Abhilfe :-(

Weitere Suchen via Google brachten dann folgenden Loesungsweg:
(siehe auch
http://blogs.koolwal.net/2009/10/11/howto-blacklisting-kernel-module-from-auto-loading-in-debian/
)

Als Erstes erstellt man sich eine Datei, die /etc/modprobe.d/dmfe.conf
in die traegt man (den sonst in die /etc/modprobe.d/blacklist einzutragende) blacklist-Eintrag

blacklist dmfe

ein.
Datei speichern.

Danach erstellt man mit dem Befehl

depmod -ae

ein neues "Dependency-File/-Map".

Da die V100 ein initrd (Intial-RamDisc) nutzt, muss das
neue Dependency-File  diesem bekannt gemacht werden mit dem Befehl

update-initramfs -u -k `uname -r` -v

da 'uname -r' bei mir als Ergebnis 2.6.26-2-sparc64 liefert
hiess bei mir der Befehl dann

update-initramfs -u -k 2.6.26-2-sparc64 -v

So nachdem die V100 ein wenig "gewuetet" hat und fertig ist, kann man
dann nochmal ordentlich durchstarten (ohne dass beide Haken stoeren)
per
shutdown -r now

Wenn man sich nach dem Neustart (ohne haengenbleiben wegen DMA)
einloggt, kann man ueberpruefen, dass sich automatisch nun
der tulip Treiber die Netzwerkports geschnappt hat wenn
man
lsmod | grep tulip
aufruft.

Im Gegnsatz dazu sollte der Aufruf
lsmod | grep dmfe
nun kein Ergebnis mehr bringen und es kann sofort nach dem
Login mit dem pingen und netzwerken begonnen werden.


So nun viel Spass mit debian auf der V100 :-))

Gruesse
Guido

sonnenblen.de - Das unabhängige Sun User Forum