Autor Thema: debian lenny 5.0.5 auf ultra 10 installationsanleitung & aufgetauchtes problem  (Gelesen 3255 mal)

Offline jmar83

  • Sobl Junior
  • **
  • Beiträge: 98
hallo zusammen,

als erster beitrag möchte ich was produktives beisteuern, deshalb hier meine installationsanleitung für debian lenny 5.0.5 auf einer ultra 10 mit 440 mhz und 2 grafikkarte (creator 3d mit 13w3-, ati rage mit standard vga-anschluss)


1. obp aktualisieren (gibt's hier: http://www.sunshack.org/data/bootroms.html) mithilfe einer solaris-minimalinstallation (gehe davon aus dass der leser solaris-versiert ist)
2. cd-rom des geräts ausbauen und dvd-laufwerk einbauen ;-)
3. debian lenny dvd-image herunterladen
4. gerät mit stop-n beim einschalten resetten
5. bei der speicherinitialisierung mit stop-a abbrechen und zum opb wechseln
6. den befehl "setenv auto-boot? false" eingeben
7. debian-dvd einlegen
8. den befehl "boot cdrom Install video=atyfb:off" eingeben
9. die installation wird nun gestartet und ist simpel einfach (weiter, weiter und nochmals weiter drücken)
10. nach der installation neu starten und am obp folgende befehle eingaben:
- "setenv boot-command boot disk Linux video=atyfb:off"
- "setenv auto-boot? true"
-  "setenv output-device screen:r1024x768x60" (hinterste zahl ist die wiederholfrequenz des monitors, 60hz für einen flachbildschirm...)
- dann neustart mit "reset-all"
11. wenn bei der installation die grafische oberfläche mitinstalliert wurde, muss in der datei /etc/X11/xorg.conf der eintrag "BusID" auskommentiert werden. statt vi benutzt man besser pico als editor! (vi ist so edlin-mässig...)

...nach meinen verfahren wird die creator 3d als grafikkarte genutzt. wenn man einen normalen bildschirm (flach oder crt mit analogem anschluss) hat, tut's z.b. dieser adapter bei 1024x768 pixeln: http://cgi.ebay.ch/ws/eBayISAPI.dll?ViewItem&item=120271501229&ssPageName=STRK:MEWNX:IT (keine angst, bin nicht der verkäufer dieses artikels!)

bei 1152x864 gibt's probleme mit dem bildrand... weiss auch nicht wie es bei 16:9 auflösungen ist, oder das die gk überhaupt schafft?

das wär's soweit... nun sollte debian mit der grafischen oberfläche starten.

ich habe sogar noch einen usb 2.0 - controller mit via-chipsatz installiert und eine maus dort angeschlossen, das funktionert! (braucht es nicht pcix für usb 2.0-transferraten??? wenn ja scheint der pci-bus der ultra 10 abwärtskompatibel zu sein!) wie auch einen scsi-controller. (uraltes teil von 1998, wird vom prom der sun scheinbar nicht erkannt, dafür aber von debian, komisch...)


nun zum weniger schönen teil der geschichte: debian stürzt alle paar stunden ab, aber nur wenn man was macht. im leerlauf habe ich das gerät ein ganzes wochenende in der firma am laufen gehabt, ohne probleme. ram's habe ich auch schon alle ausgetauscht, dummerweise muss man diese edo-ram's (mit ecc) immer paarweise verwenden... meine beiden erweiterungskarten (usb u. scsi) auch entfernt. dabei handelt es sich um richtig heftige abstürze, wo man komplett nichts mehr machen kann, mauszeiger bewegt ich nicht mehr, tastatur reagiert nicht mehr, selbst der obp über stop-a ist nicht mehr ansprechbar...

ein hitzeproblem wird's kaum sein, ram's bin ich unsicher (wegen dem zwang der paarweisen verwendung). also möglicherweise auch ein softwareproblem. könnte es noch sein dass debian irgendwo auf low-level-ebene (kernel) einen bug hat? und ausgrund dessen das system dermassen "einfriert" ?

wer weiss weiter?

oder hat jemand eine sun wo ein linux (mit graf. oberfläche) anständig funktioniert? wenn ja möge er mir bitte mitteilen um welches gerät es sich handelt. dann kann ich die alte ultra 10 wegwerfen, oder noch besser, ein 1. august-feuer daraus machen (1.8. ist ch-nationalfeiertag), nein spass beiseite...;-)


grüsse, jan
grüsse, jan

sonnenblen.de - Das unabhängige Sun User Forum


Offline jmar83

  • Sobl Junior
  • **
  • Beiträge: 98
hat niemand die geringste ahnung? habe mit jetzt eine sun blade bestellt, mal schauen ob's damit klappt...?
grüsse, jan

Offline Ebbi

  • Sobl Administrator
  • Sobl Guru
  • *****
  • Beiträge: 1313
  • Minusgeek
hat niemand die geringste ahnung?
Naja, geringe Ahnung schon.
Aber ich bleibe dabei, dass man für Linux keine Sun braucht. Dafür gibt's Solaris. :)
Ich hatte mir als kleinen Exkurs auf die Blade 1000/2000 ein Gentoo aufgenudelt.
Das ging erstaunlich schmerzfrei.
Allerdings ohne X-Server, denn da fehlt die Unterstützung für die meisten Sun-Karten (WIMRE).
Möglicherweise kann man aber vielleicht eine beliebige PCI-Grafik verwenden.
Die würde dann aber beim Booten mangels Sun-Unterstützung dunkel bleiben.