Neueste Beiträge

Seiten: [1] 2 3 ... 10
1
Sun SPARC / Antw:Star-Probleme
« Letzter Beitrag von escimo am 19. Juli 2018, 20:09:38 »
Hab alles nachDeinen Angaben erledigt und Externe Geräte entfernt. Internes auf Adresse 6 gestellt (...)
Was bedeutet "Internes auf Adresse 6 gestellt" ? - interne SCSI-Geräte (d.h. Festplatten) sind nicht "verstellbar", wie in einem der Beiträge bzw. im ServiceManual aufgeführt.  ;)

Alles klar, dann bis die Tage. :)
2
Sun SPARC / Antw:Star-Probleme
« Letzter Beitrag von Sparcy am 19. Juli 2018, 18:25:17 »
Hallo Stepfan,
Neugier ist der beste Motivator.
Hab alles nachDeinen Angaben erledigt und Externe Geräte entfernt. Internes CD-Laufwerk auf Adresse 6 gestellt und siehe da. der Bildschirm sieht so aus. :) :) :) :)

Banner        SPARCstation 5, Keyboard Present
Banner        ROM Rev. 2.29, 128 MB memory installed, Serial #80123456.
Banner        Ethernet address 8:0:20:53:55:4e, Host ID: 80123456.

Ich habe von CD gebootet und solaris 2.5.1 hat sich gemeldet.
Es haben sich noch einige Fehler gezeigt aber diese abzuschreiben habe ich im Moment keine Zeit.
Zumindest war Deine nette Unterstützung von Erfolg gekrönt, Danke.

Frage, hat wohl jemand einen 68pin Endwiderstand? Könnte mit einem 68pin Verbindungskabel Tausch anbieten und mit Original-CD´s  Treiber und Solaris 2.6

Ich melde mich wie geschrieben.
3
Sun SPARC / Antw:Star-Probleme
« Letzter Beitrag von escimo am 19. Juli 2018, 15:58:41 »
Ps. Mein Bastelkumpel hatte mir signalisiert, das CD Laufwerk terminiert sich automatisch (hinten LED) und benötigt keinen Endwiderstand????????
Was ist nun richtig, ich hab keine Erfahrungen in der Sache.
Auto-Terminierung? Gut, dann ist das der gewünschte Zustand. Nix mehr zu tun.
4
Sun SPARC / Antw:Star-Probleme
« Letzter Beitrag von Sparcy am 19. Juli 2018, 14:11:31 »
Hallo Stephan,
großes Kompliment für Deine Mühe.
Ich werde mich für ein paar Tage nicht melden und nicht mit dem Problem beschäftigen weil, sportlich eingespannt.
Werde aber an der Sache bleiben und mich spätestens Ende nächste Woche melden und berichten.
Ganz lieben Dank

Ps. Mein Bastelkumpel hatte mir signalisiert, das CD Laufwerk terminiert sich automatisch (hinten LED) und benötigt keinen Endwiderstand????????
Was ist nun richtig, ich hab keine Erfahrungen in der Sache.
5
Sun SPARC / Antw:Star-Probleme
« Letzter Beitrag von escimo am 18. Juli 2018, 22:26:31 »
NVRAM ist nun mit Datum/Zeit/Ethernet Adresse/Serial/Host gespeichert. Batterie ist nagelneu auf dem reparierten Prom.
Gut. Was gibt dir das folgende Kommando zurück?

  ok .idprom

Hier noch ein Paar Infos, die du wahrscheinlich schon hast:
Es stellt sich mir die Frage, muß am ext. CD-Laufw. am OUT ein Endwiderstand stecken? Beim Tape steckt einer. Für CD hab ich keinen.
Ja, wenn es das letzte Gerät am Bus ist. Da vorher das Tape dazwischen hing und es einen Endwiderstand hatte, terminierte es damit den Bus und das CD-Laufwerk konnte nicht angesprochen werden. Alternative: aktiver Terminator am externen SCSI-Anschluss des CD-Laufwerksgehäuses.

so wie im Zitat sieht es nun aus, nur eben mit meinen Gerätetypen. ich denke ich bin auf einem guten Weg, oder ??
Passt.

The IDPROM contents are invalid / der IDPROM Inhalt ist ungültig ????????????? da häng ich
Mmm. Da ist was schiefgegangen.
Die alte Ethernet address (MAC) hattest du nicht mehr, korrekt? Ab und zu ist die auch auf dem NVRAM oder dem EPROM als Aufkleber nachträglich aufgebracht. Neuere NVRAMs haben i.d.R. einen Aufkleber, mit einem Code über den sich die HostID und MAC beim Hersteller erfragen lässt. Das könnte aber nach der Übernahme durch Oracle schwer werden. Keine Anhnung, ob im Sun-Museum in Dreieich noch jemand "da" ist, der noch eine digitale Liste "rumfliegen" hat.

Kein Problem. Der Vorgang lässt sich wiederholen. Zum Programmieren präferiere ich die "langsame" Methode. Nach <Strg> + <A> am OpenBootPROM Prompt ("ok" auslassen/nicht eingeben und nicht vertippen)  ;D
  ok 1 0 mkp
  ok 80 1 mkp
  ok 8 2 mkp
  ok 0 3 mkp
  ok 20 4 mkp
  ok 53 5 mkp
  ok 55 6 mkp
  ok 4e 7 mkp
  ok 0 8 mkp
  ok 0 9 mkp
  ok 0 a mkp
  ok 0 b mkp
  ok 12 c mkp
  ok 34 d mkp
  ok 56 e mkp
  ok 0 f 0 do i idprom@ xor loop f mkp
  ok reset


Nach dem Warmstart sollte die Meldung bzgl. "invalid idprom contents" verschwinden.
Am OBP Prompt sollten dann neben dem Banner in etwa folgende Werte zu sehen sein (ähnlich diesem)
<HERE>        SPARCstation 5, Keyboard Present
<SOME>        ROM Rev. 2.15, 128 MB memory installed, Serial #0000000.
<LOGO>        Ethernet address 8:0:20:53:55:4e, Host ID: 80123456.


Nicht vergessen...
  ok setenv diag-switch? false
  ok setenv auto-boot? false
  ok setenv selftest-#megs 1


Übrigens, habe ich gerade festgestellt, nach Wühlen in den Beiträgen, NVRAM habe ich nach Deinen Angaben repariert. Sehr schön beschrieben, Kompliment.
Ich bin unschuldig. Habe auch nur befolgt was andere bereits zusammengeschrieben haben (NVRAM FAQ oben) ;)

Gruß, Stephan
6
Sun SPARC / Antw:Star-Probleme
« Letzter Beitrag von Sparcy am 16. Juli 2018, 19:03:13 »
Hallo Stephan,
respekt, das ist nicht wenig Info. Dazu habe ich mir das Manual heruntergelade, alter Falter, da hab ich eine längere Lektüre. Nun gut, ich fummel mich mal durch.
NVRAM ist nun mit Datum/Zeit/Ethernet Adresse/Serial/Host gespeichert. Batterie ist nagelneu auf dem reparierten Prom.
Es stellt sich mir die Frage, muß am ext. CD-Laufw. am OUT ein Endwiderstand stecken? Beim Tape steckt einer. Für CD hab ich keinen.
Beim OBP-Word "probe-scsi-all" würde ich in etwa das folgende erwarten (Auszug aus dem ServiceManual, p. D-7)

ok probe-scsi-all
/iommu@0,100000000/sbus@0,10001000/espdma@5,8400000/esp@5,8800000
Target 1
 Unit 0 Disk CONNER CP30548 SUN0535AEBX93081QTT
Target 3
 Unit 0 Disk CONNER CP30548 SUN0535AEBX93081QTT
Target 6
 Unit 0 Removable Read Only device TOSHIBA CD-ROM XM-4101TA289310/16/93


so wie im Zitat sieht es nun aus, nur eben mit meinen Gerätetypen. ich denke ich bin auf einem guten Weg, oder ??

Beim Start:
Probing Memory Bänke 0-3 je 32MB
.........CPU  FMI,MB86907
iommu@0,10000000/sbus@0/10001000 at 5,0 espdma espsd st SUNW, bppledm a le
.........at 4,0 SUNW, CS4231 power mamagement
         at 1,0 dma esp sd st
         at 2,0 dma esp sd st lebuffer le
         at 3,0 cgsix
         at 0,0 Nothing there

The IDPROM contents are invalid / der IDPROM Inhalt ist ungültig ????????????? da häng ich

Boot device/iom...../sbus/ledma@5,400010/le@5,8c00000 File and args:
Timeout waiting for ARA/RARP packet

Übrigens, habe ich gerade festgestellt, nach Wühlen in den Beiträgen, NVRAM habe ich nach Deinen Angaben repariert. Sehr schön beschrieben, Kompliment.
7
Sun SPARC / Antw:Star-Probleme
« Letzter Beitrag von escimo am 16. Juli 2018, 17:04:19 »
Beim OBP-Word "probe-scsi-all" würde ich in etwa das folgende erwarten (Auszug aus dem ServiceManual, p. D-7)

ok probe-scsi-all
/iommu@0,100000000/sbus@0,10001000/espdma@5,8400000/esp@5,8800000
Target 1
 Unit 0 Disk CONNER CP30548 SUN0535AEBX93081QTT
Target 3
 Unit 0 Disk CONNER CP30548 SUN0535AEBX93081QTT
Target 6
 Unit 0 Removable Read Only device TOSHIBA CD-ROM XM-4101TA289310/16/93

8
Sun SPARC / Antw:Star-Probleme
« Letzter Beitrag von escimo am 16. Juli 2018, 16:58:22 »
Ich empfehle, schau' in jedem Fall auch in das oben verlinkte ServiceManual zur SPARCstation 5. Das ist unentbehrlich.

The IPPROM contents are invalid
NVRAM-Batterie ist leer! Alle Werte werden damit auf die Standardwerte (defaults) beim Einschalten zurückgesetzt. Wenn die Batterie beim NVRAM leer ist, "vergisst" dieser alle vom default abweichenden Einstellungen (u.a. Boot-Reihenfolge, Datum, HostID, MAC, ...) und setzt diese auf Standard (Default) zurück. Unter anderem:
  auto-boot? true
  diag-mode? true
  boot net


OpenBoot Prompt(ok)  erscheint leider nicht weil

Timeout waiting for ARP/RARP packet
lost carrier (transceiver cable problem?)(...)
Nein, sondern wie die Ausgabe auch zeigt, dass "default" von Netz zu booten ist. Die Tastenkombo <Strg>+<A> sollte umgehend nach dem Einschalten erfolgen und greift immer, nur später beim Netz-Boot wohl nicht mehr (Timeout waiting for ARP/RARP packet)

Habe die Externen Laufwerke nach Deinen Angeben terminiert CD ID4 / Tape ID6
internes Laufwerk ausgebaut
umgekehrt:
CD --> ID6
Tape --> ID4
erste Festplatte --> ID3 (unterer, interner Slot)
zweite Festplatte --> ID1 (oberer, interner Slot)
Die internen Festplatten erhalten automatisch die SCSI-IDs beim SCA-Anschluss zugewiesen, also ID3 und ID1.

Für das CD-ROM Laufwerk existiert i.d.R. ein Alias der auf Target (ID) 6 zeigt.
Das CD-Laufwerk kann nicht gefunden werden. Da stimmt also etwas mit der Jumper-Konfiguration, der Verkabelung, der Terminierung oder gar dem Laufwerk selbst nicht.
Das CD-Laufwerk sollte ferner 512 kByte Blockgrößen unterstützen bzw. darauf operieren, nicht 2048 kByte! Das lässt sich i.d.R. über Jumper einstellen. Auch mal in die Doku zum CD-Laufwerk schauen.
Sonst nimm erst mal das Tape aus der "SCSI-Kette" raus, also nur das externe CD-Laufwerk an die SS5 anschließen.

Also, ich habe mal einen 2.NVram gefummelt. Habe glücklicherweise 2 Motherbords.

Ich denke das macht die Hilfe einfacher weil ich nun auf ANFANG stehe, oder?
Nicht unbedingt. Das Vorgehen ist identisch zu oben.

Zustand beim Einschalten:

Starting realtime clock...
Incorrect configuration checksum;
SettingNVRAM parameters to default alues.
Setting diag-switch? NVRAM parameter to true

Serial #0
Ethernet address 0:0:0:0:0:0
Host ID: 00000000
 
Vorgaben abgearbeitet:
Target 4 / Tape EXABYTE
Target 1 / Disk SUN 4.2
Target 3 / Disk Sun 2.1
Target 0 / nicht present code-1
Target 6 / nicht present code-1 / eigentlich externes CDROM
Auch hier:
NVRAM-Batterie leer (HostID leer, MAC leer). Alle Einstellung auf Standardwerte zurückgesetzt.
Target 3 / Disk Sun 2.1 ist die erste, interne Festplatte
Target 6 oder 0 wird nicht gefunden. Wie bereits angegeben: SCSI-ID des CD-ROM Laufwerks, Terminierung und Blockgröße prüfen.


Eine Reparatur des bestehenden NVRAM bzw einen neuen NVRAM (oder Adapter) sehe ich als notwendige Voraussetzung.
Andernfalls ist man aufgefordert bei jedem Kaltstart alle erforderlichen Parameter im OBP neu zu setzen.

Gruß, Stephan
9
Sun SPARC / Antw:Star-Probleme
« Letzter Beitrag von Sparcy am 16. Juli 2018, 12:48:34 »
Also, ich habe mal einen 2.NVram gefummelt. Habe glücklicherweise 2 Motherbords.

Ich denke das macht die Hilfe einfacher weil ich nun auf ANFANG stehe, oder?
Zustand beim Einschalten:

Starting realtime clock...
Incorrect configuration checksum;
SettingNVRAM parameters to default alues.
Setting diag-switch? NVRAM parameter to true

Serial #0
Ethernet address 0:0:0:0:0:0
Host ID: 00000000
 
Probe-scsi-all
Target 4 / Tape EXABYTE
Target 1 / Disk SUN 4.2
Target 3 / Disk Sun 2.1
Target 0 / nicht present code-1
Target 6 / nicht present code-1 / eigentlich externes CDROM

probe-scsi:
Target 0 / Toshiba internes CDrom
Target 1 / Disk SUN 4.2
Target 3 / Disk SUN 2.1
10
Sun SPARC / Antw:Star-Probleme
« Letzter Beitrag von Sparcy am 16. Juli 2018, 10:35:50 »
Moin Stephan,

The IPPROM contents are invalid

OpenBoot Prompt(ok)  erscheint leider nicht weil

Timeout waiting for ARP/RARP packet
lost carrier (transceiver cable problem?)
cable problem ortwisted pair hub link-test disabled
use then PROM command "help ethernet" for more information.

Timeout wartet auf ARP / RARP-Paket
verlorener Träger (Transceiver Kabel Problem?)
Kabelproblem oder twister Pair Hub-Test deaktiviert
Verwenden Sie dann den PROM-Befehl "help ethernet" für weitere Informationen.

In der Schleife hänge ich nun fest

Habe die Externen Laufwerke nach Deinen Angeben terminiert CD ID4 / Tape ID6
internes Laufwerk ausgebaut
Kombo Strg + A funktioniert nicht
Seiten: [1] 2 3 ... 10